Datto Windows Agent: Error: Operation Timed out After (X) Milliseconds with 0 Bytes Received

Issue

When you try to start a backup for a system protected by the Datto Windows Agent (DWA), you receive the error message, "Operation Timed out After (x) Milliseconds with 0 Bytes Received."

Environment

  • Datto Windows Agent

Cause

Timeout errors are often caused by network or server performance issues. Troubleshooting should focus on those areas.

Resolution

Follow the steps below to troubleshoot the issue.

  1. For the Datto Windows Agent, open an elevated command prompt with administrator privileges on the target machine, and run vssadmin list writers. If this command takes more than 60 seconds to respond, you may need to wait for any outstanding shadow copies or other backup processes to complete before starting a new backup. If there are no backup processes currently running, troubleshooting should focus on the VSS writers. See Resolving VSS Writer Errors in Windows 8, Server 2012, and Up for further steps in this scenario.
  2. You may see this error when there is a mismatch between the MTU setting on the Datto device and your network Ensure jumbo frames are disabled in the Datto device GUI:
    1. From the Configure tab, navigate to Networking> Settings>IP Settings.
    2. You'll see a radio button to disable jumbo frames. Click Disabled then click APPLY.

fig1.PNG
Figure 1: Jumbo Frames

  1. Review Datto's networking and bandwidth requirements article to ensure your machine meets all networking requirements.
  2. Ensure that any other resource-intensive actions are not happening when you wish to back up the server (defrags, disk optimizations, database backups or optimizations, etc.).
  3. Check resource usage to ensure the server is not reaching saturation during backup times.

Windows 10 Server 2012/2016 network:

  1. Open Task Manager and go to the Performance tab.
  2. Select the active Ethernet port and check utilization. Open a run window and type resmon for more detailed information about resource usage.

Windows 10 Server 2012/2016 general load:

  1. Open Task Manager and go to the Performance tab.
  2. Select CPU, Memory, and Disks to view the usage of each. Open a run window and type resmon for more detailed information about resource usage.
  3. As a last resort, restart the following services:
    • Datto Backup Agent Service.
      Ensure that you have this service set to automatic startup and running even when a backup is not in progress. To restart, stop the service, wait a few seconds, then click start. Do not use restart.
    • Datto Provider.
      Ensure that you have this service set to automatic startup. It should not be running if a backup is not in progress. If it is running, but the UI does not show a backup taking place, stop the service, and leave it stopped.

Additional resources