Datto Networking: Resolving Faulted LACP Negotiation

Follow

Issue

You receive a Faulted LACP negotiation error when trying to configure NIC Teaming (LACP) between a Datto Switch and Windows Server 2012 R2.

Environment

  • Datto Switches

Cause

LACP requires the server and switch to have the same time-out setting. By default, Datto switches are set to slow time-out. If the settings do not match, you will see a Faulted LACP negotiation error in the Windows NIC Teaming interface.

Figure 1: Faulted LACP negotiation error (click to enlarge)

Resolution

Although Datto can recommend changes to the Windows registry, always confirm with a Microsoft expert that the recommended changes are compatible with your environment before making any changes.

Microsoft has published a hotfix enabling slow time-out on the server:

This worked when the following variables match:

  • Teaming mode: LACP
  • Load balancing mode: Dynamic

Figure 2: NIC team properties (click to enlarge)

Additional Resources


Was this article helpful?

0 out of 0 found this helpful

You must sign in before voting on this article.

Want to talk about it? Have a feature request?

Head on over to our Community Forum or get live help.