Scope
This article covers the cause and possible solution for the following error:
Final error (-32 The process cannot access the file because it is being used by another process.)
Cause
- The ShadowSnap installation was interrupted.
- There was a previous version of ShadowProtect installed on the target machine, and the ShadowSnap installer was installed over the incompatible ShadowProtect installation.
- Previous ShadowProtect versions were not completely uninstalled.
Solution
1. Re-install the ShadowSnap agent using the PsExec software according to this article:
2. If the repair install did not succeed:
- Remove ShadowSnap and all versions of ShadowProtect from the server.
- Reboot the server.
- Re-install ShadowSnap using the method specified above.
- Reboot the server.
3. If the issue persists, check anti-virus programs to ensure no files are being protected or blocked through the Program Files (x86)/StorageCraft
folder.
4. After doing the above steps, if this issue continues, contact Datto Technical Support for further assistance.