SIRIS, ALTO, and NAS: Error: "Unexpected End Of The Image File"

Follow

Issue

This article goes over the possible cause and solutions to the following error: "Unexpected End of the Image File."

Environment

  • ShadowSnap Agent

Cause

  1. The backup agent attempted to backup the target, but when writing to the sparse image file, it reached the end while expecting more data.
  2. The partitions of the device were recently increased in size, and the agent attempted to write beyond the scope of the sparse image.
  3. The disk image was interrupted mid-transfer.

Resolution

After going through these possible solutions and it is still showing this error, please contact Datto Technical Support for further assistance.
  1. Make sure there is two-way communication between the protected machine and the Datto device on the device's Port 25566.
    • Perform networking tests to ensure that a stable route is identified and present.
  2. If a volume was recently resized, select that volume from the Configure Agent tab under Volume Level Backup Control, and temporarily exclude it in order to delete the image for that particular volume through the Datto appliance's web interface (Figure 1). There will be a warning message before following through, select OK (Figure 2).
  3. Start a new backup, and allow time for the sparse file to be regenerated.

Figure 1: Volume-Level Backup Control

Figure 2: Warning Message


Was this article helpful?

1 out of 2 found this helpful

You must sign in before voting on this article.

Want to talk about it? Have a feature request?

Head on over to our Datto Community Forum or the Datto Community Online.

For more Business Management resources, see the Datto RMM Online Help and the Autotask PSA Online Help .

Still have questions? Get live help.

Datto Homepage