Error: Backup failed due to insufficient resources on the protected system

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Issue

When you try to start a backup for a system protected by the ShadowSnap Agent, you receive the error message, "Backup failed due to insufficient resources on the protected system."

In legacy versions of the Datto IRIS environment, this error message was "Snapshot returned error code -1450."

Cause

Causes for this error message can vary. Common underlying conditions include:

  • Insufficient available RAM
  • Insufficient buffer space
  • Insufficient available space on hard disk for shadow storage to occupy
  • Significant disk fragmentation

Resolution

If the system is a 32-bit system, consider upgrading the server to 64-bit hardware with a 64-bit OS and more RAM. 

Follow these steps to solve the problem:

  1. Rule out any processes that are taking up large amounts of resources. A minimum of 20% free space per protected volume, and 1 GB of RAM, need to be available on the production machine. If resources fall below these thresholds, backups will fail.
     

     Volume Use

    Status

    Comments

    0 – 70%

    Good

    Use is good.

    71 – 80%

    Warning

    Use is outside optimal limits. Monitor the volume growth and look at cleaning up unnecessary files and moving non-essential data to other storage.

    81 – 100%

    CRITICAL

    Volume is becoming critical. Snapshots will start to fail, disk queue lengths will increase. Create space.

    Figure 1: StorageCraft disk space best-practices.

  2. Make sure the ShadowSnap agent version is 3.0 or newer, as this release has better resource use.
  3. Increase the paging buffer size on the server, and if possible, move the page file to a data volume.
  4. Make sure the drive has no significant level of fragmentation.
  5. Review the ShadowProtect server tuning guide and make the recommended registry changes.

     

StorageCraft troubleshooting tips for reducing disk I/O:

From VSS Errors 12293 and 12298: What does it all mean? (external link): 

Apply the following Microsoft KB patches to the production machine. If your production machine is running Microsoft Server 2003, you may not see the patches listed in Windows Updates. If they do not appear, you will need to download them directly from the Microsoft Support website.

  • http://support.microsoft.com/kb/940349
  • http://support.microsoft.com/kb/967551
  • http://support.microsoft.com/kb/972623

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