Failed screenshot with blue screen stop code 0x0000007b

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Issue

When starting a virtualization, or when performing a screenshot verification of a protected machine, you briefly see a 0x0000007b blue screen error failure state, followed by a reboot.

Figure 1: Screenshot failure with blue screen

Environment

  • Datto SIRIS
  • Datto ALTO

Cause

  • The driver for the selected virtualization storage controller is missing, incompatible, or corrupt.
  • A Group Policy setting on the production machine is causing a 0x0000007b error on virtualization.

Solution

1. Change the storage controller listed in the Configure Agent Settings page for the impacted system. For Vista and newer operating systems, try SATA or SCSI. Older operating systems may require one of the IDE controller options.


Figure 2: Virtualization Storage Controller setting

2. After changing the storage controller setting, attempt another virtualization or screenshot verification, and observe the results.

3. If the issue persists, ensure that the following Group Policy settings are not enforced on the Agent:

  • Computer Configuration → Policies → Administrative Templates → System → Device Installation → Device Installation Restrictions → Prevent installation of removable devices
  • Computer Configuration → Policies → Administrative Templates → System → Device Installation -> Device Installation Restrictions → Prevent installation of devices using drivers that match these device setup classes


Figure 3: Prevent installation of removable devices (click for larger image)


Figure 4: Prevent installation of devices using drivers that match these device setup classes (click for larger image)

4. If both settings are disabled, ensure that the group policy setting is actually applied to the production machine by following the steps in this article. Certain antivirus applications, such as ESET Antivirus, have been known to override these registry entries.

5. After performing steps 3 - 4, perform a new backup of the affected machine. Attempt a virtualization or screenshot of the new point created, and observe the results.

6. If the problem persists, force a differential merge of the affected system. When the backup completes, attempt a virtualization or screenshot of the new point created, and observe the results.

7. If the issue persists, contact Datto Technical Support for further assistance.

 


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