Unable to start backup because agent service is stopped

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1. Scope

This article describes the cause and possible solution for the error Unable to start backup because agent service is stopped.

2. Cause

Most commonly, this issue can be traced to a problem with the ShadowSnap agent services on the protected agent.

  1. On the protected machine, one or more of the three services associated with ShadowSnap are not running. The services are as follows:

    • StorageCraft Raw Agent
    • StorageCraft ShadowCopy Provider
    • ShadowProtect Service

  2. The protected machine has not been rebooted since the original ShadowSnap installation.

  3. TCP port 25566 is blocking communication between the ShadowSnap Agent Service and the Datto device.

3. Solution

If you have not done so already, follow the preliminary steps in the Start Here article.

  1. Open up ShadowProtect, and verify that the license status in the lower left corner of the ShadowProtect screen shows as Active.



  2. Stop the StorageCraft Raw Agent service, StorageCraft ShadowCopy Provider service, and ShadowProtect Service, and then start them again, beginning with the Raw Agent Service.
  3. Repair Agent Communications.
  4. If the protected machine has not been rebooted since ShadowSnap was installed, reboot this machine before beginning your first backup.
  5. If this continues to fail, open TCP Port 25566 between the device and the protected machine. The StorageCraft Raw Agent service will listen on this port by default, once started. Ensure that no other services are attempting to listen on that port.
  6. If the Raw Agent stops while the agent is backing up or right after a backup, the cause could be antivirus software running on the system.

    To prevent this from happening, create a whitelist exclusion within the anti-virus for the entire StorageCraft folder. This is the path that will need to be added:

    C:\Program Files (x86)\StorageCraft

    The agent can also be stopped during a virus scan if the exclusion is not made.


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