SIRIS, ALTO and NAS: DEBIAN FRONTEND error

Follow

Issue

When you run device updates on a Datto appliance, you get the error: "DEBIAN_FRONTEND=noninteractive apt-get install -f indicated dependency issues. Please correct."

Environment

  • Datto SIRIS
  • Datto ALTO
  • Datto NAS

Cause

This error is caused by package dependency issues on the Datto device's OS. It means that the appliance is missing some of the packages needed to bring itself up to date.

Resolution

Because packaging errors happen due to a variety of causes, you must call Datto Technical Support to have one of our Tech Support Experts troubleshoot this issue.


Was this article helpful?

0 out of 0 found this helpful

You must sign in before voting on this article.

Want to talk about it? Have a feature request?

Head on over to our Datto Community Forum or the Datto Community Online.

For more Business Management resources, see the Datto RMM Online Help and the Autotask PSA Online Help .

Still have questions? Get live help.

Datto Homepage