What do I need to know about Google's upgrade to OAuth 2.0?

Follow

As of April 2015, Google no longer supports OAuth 1.0 for authentication and authorization. In preparation for this change, Backupify/Datto SaaS Protection upgraded our code to use OAuth 2.0, the new standard.
 
The upgrade gives admins additional control on which apps have access to which users’ data from the Google Admin panel.
 
For most domains, this change will happen seamlessly, with no user intervention necessary.  (You may get an email from Google when the migration is progressed.) Based on the current authorization type or permission set, a certain subset of domains will be asked to re-authorize their domains with Backupify/Datto SaaS Protection. If your domain is one that needs to re-authorize, all you need to do is to log into Backupify/Datto SaaS Protection and click to Integrate with Google.
 

You’ll be prompted to grant permissions to Backupify/Datto SaaS Protection to access your data for backup, accept these terms, and your domain will be set up on OAuth 2.0. Backups for all of your users will now use the new standard.
 

If you’ve re-authorized your domain, you may notice that both the OAuth 1.0 app and the OAuth 2.0 listing will both be present in your Marketplace Apps in the Google Admin panel. You can safely remove the OAuth 1.0 app.

-
 
To contact Backupify/Datto SaaS Protection support, click here to submit a Support Request, or click here for more contact options.


Was this article helpful?

0 out of 0 found this helpful

You must sign in before voting on this article.

Want to talk about it? Head on over to our Community Forum!