Android Devices Are Not Connecting to Splash Pages On Datto Access Points

Issue

Android devices are not redirected to the captive portal when the user gets connected to the WiFi network.

Environment

  • Datto Access Points
  • Android Devices

Cause

The captive portal is not redirecting the user to the splash page.

Resolution

How Android determines if it has an internet connection:

Android devices send a request to a page called generate_204 hosted on the following sites:

If the redirect is not properly set up, a blank page will display instead of the splash page, and the user will be unable to authenticate for internet access.

Verifying an Internet connection on Android devices

1. On your Android device, disconnect from your current internet session.

2. Connect to your WiFi network.

3. Open an incognito or private session in a web browser such as Google Chrome.

4. Navigate to http://clients3.google.com/.

Resolving the issue

Ensure that your Datto captive portal configuration blocks access to Google and other external sites:

1. Navigate to a device web session for your access point.

2. Click the Configure drop-down and choose the SSID hosting your captive portal.

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Figure 1: The Configure tab expanded

3. Make sure Splash Pages is toggled on, then click Verify Walled Garden Settings.

4. Add the following Google-associated addresses to the walled garden list to ensure these sites are accessible to unauthenticated users:

  • http://clients1.google.com/
  • http://clients3.google.com/
  • http://connectivitycheck.gstatic.com
  • http://connectivitycheck.android.com


Figure 2: The walled garden site list

5. Toggle Block Unauthenticated Users on to block port access to external websites for any user who has not authenticated through the Captive Portal.


Figure 3: Block unauthenticated users