Datto Autotask PSA: Duplicate Devices Appear in Autotask PSA

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Issue 

Duplicates of my Datto devices (configuration items) appear in Autotask PSA's Configuration Items screen.

Environment 

  • Datto Autotask PSA

Cause

  • Devices configured in Autotask PSA 1.0 were indexed by device hostname. In Autotask PSA 2.0, devices are now indexed by model number. If you upgraded to 2.0, the existing devices may remain, still listed by hostname, and also get re-added and listed by model number. 
  • If you try to manually add devices through the Autotask PSA Admin menu, this will not correctly map them to the integration.
  • If you use both Autotask and Datto RMM, and have configured both to integrate with the Partner Portal, duplicate devices may result. 

Solution

  • Delete any devices referenced by hostname; retain the duplicates referenced by model number.
  • Delete any devices created through the Autotask PSA Admin menu, then enable them in the Datto Partner Portal. 
  • Configure the device sync between Datto RMM and Autotask PSA to not sync Datto devices; the devices should be directly synced from the partner portal to Autotask PSA. 

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For more Business Management resources, see the Datto RMM Online Help and the Autotask PSA Online Help .

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