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Missing Files when Restoring an External NAS Share

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Issue

When restoring an external NAS share, you notice that one or more files or folders are missing from the backup.

Environment

  • Datto SIRIS
  • Datto ALTO
  • Datto NAS

Cause

1. The user account that the NAS Guard feature is using to connect to the production environment does not have full administrator access to the protected share. As a result, the Datto appliance cannot read one or more files or folders in the share.

2. This error can be directly related to the One or more files were copied unsuccessfully due to lack of permissions backup failure.

Resolution

1. Access the Protect page of your Datto appliance. Click the Show Backup Logs link for the share experiencing the issue.

2. Review the logs shown. Search for the error "One or more files were copied unsuccessfully due to lack of permissions," as shown in Figure 1. Make note of the files which did not successfully copy.

Note: The Protect page only shows the most recent backup logs. Clicking the Show more... link in the lower left-hand corner of the digest will display extended logging information.

Figure 1: One or more files were copied unsuccessfully (click to enlarge)

2. Click the Configure Share Settings link for the selected share. From the Change Connection Settings card, review the access credentials listed.

3. If the listed credentials are correct, access the production machine, and verify that the account used has access to the files which failed to copy. Resolve any issues found.

4. If the credentials shown are not an account with administrative access to the share, update the configuration with the username and password of a user account with the appropriate level of access.

3. Take a new snapshot of the share, and observe the results by reviewing the backup logs and by performing a test restore.


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