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Direct to Cloud: "Unable to get registration information. Will try again later."

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Issue

During the Direct to Cloud registration process, you see the error message "Direct to Cloud: Unable to get registration information. Will try again later" in the Windows Notification Center.

Environment

  • Datto Direct to Cloud

Cause

  • The protected machine does not have connectivity to the Internet.
  • The protected machine is unable to communicate over port 443.
  • The protected machine is unable to resolve mothership.dtc.datto.com.
  • The Direct to Cloud registration server is down.

Resolution

1. Verify that the protected machine has connectivity to the Internet over port 443.

2. Verify that the protected machine is able to resolve mothership.dtc.datto.com.

3. Re-run the registration process by right-clicking the Direct to Cloud icon in the Windows Notification Center and selecting Open DTC registration page, as shown in Figure 1. 

Figure 1: Open DTC registration page

4. If you continue to experience this error, contact Datto Technical Support for further assistance.

Additional Resources


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