Critical backup failure: Could not update agent metadata

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Issue

Backups of ShadowSnap protected machines fail with the error message "Critical backup failure: Could not update agent metadata."

Environment

  • Datto SIRIS
  • Datto ALTO
  • ShadowSnap Agent

Cause

This a general error that displays when a backup attempt fails. The actual error message is present within the Agent Logs.

Resolution

1. In the Datto appliance's GUI, click the Protect tab and navigate to the affected agent's section on the Backup Agents page.
2. Click Show Backup Logs, as shown in Figure 1.
3. Click Show Agent Logs, as shown in Figure 1. A detailed error message relating to the backup failure will display in the logs. Use this error message to troubleshoot the backup issue.

Figure 1: Steps to show agent logs (click to enlarge)


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