Datto RMM: Time Machine Monitor reports, “Time Machine has not yet performed a backup on this machine,” on macOS 10.14 devices

Follow

Issue

When you attempt to deploy and view a device running macOS 10.14 on the Time Machine Monitor, the monitor reports the error, "Time Machine has not yet performed a backup on this machine."

Environment

  • Datto RMM
  • macOS 10.14 Mojave

Cause

Mac devices running macOS 10.14 Mojave are not able to make use of the Time Machine Monitor [MAC] component without first making security changes to the endpoint.

Resolution

You can also identify this issue by typing the following in Terminal:

tmutil latestbackup

If the issue is present, you'll see the following output:

The operation could not be completed because tmutil could not access private application data on the backup disk. Use the Privacy tab in the Security and Privacy preference pane to add Terminal to the list of applications which can access Application Data.

To resolve this issue, configure the Mac device so that tmutils (the command line utility used by this component) can access the needed data.

1. Open System Preferences, then click Security & Privacy.

aem1.jpgFigure 1: System Preferences (click to enlarge)

2. Click the Privacy tab, then click the padlock to allow editing of these settings.

3. In the left pane, click Full Disk Access and add Terminal and AEM Agent.app to the list of applications.

aem2.jpgFigure 2: Privacy tab (click to enlarge)

Additional Resources


Was this article helpful?

0 out of 1 found this helpful

You must sign in before voting on this article.

Want to talk about it? Have a feature request?

Head on over to our Datto Community Forum or the Datto Community Online.

For more Business Management resources, see the Datto RMM Online Help and the Autotask PSA Online Help .

Still have questions? Get live help.

Datto Homepage