Datto Mac Agent: "Backup failed because of a problem with making a backup request to the agent"

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Issue

When you attempt a backup of a machine protected by the Datto Mac Agent, you receive the error message, "Backup failed because of a problem with making a backup request to the agent."

Environment

  • Datto Mac Agent
  • Datto SIRIS
  • Datto ALTO

Cause

  • The Datto appliance attempted to send a backup request to the Datto Mac Agent, but it received an "Error 400 (Bad Request)" response.
  • The Datto Mac Agent cannot backup macOS devices with File Vault enabled.

Resolution

1. Disable File Vault on the affected macOS machine by following the steps described in the Turn off File Vault section of Apple's Use FileVault to encrypt the startup disk on your Mac (external link) article.
3. Verify the Datto device can reach the protected machine over your network.
4. Make sure the Datto Mac Agent is properly installed on the protected machine, and that the agent icon in its dock is green.
5. Ensure that your protected machine meets all ongoing requirements for running the Datto Mac Agent.

If none of the above steps resolve the issue, gather logs and contact Datto Technical Support.

Additional Resources


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