ALERT: Datto Drive Cloud service will no longer be available as of July 1, 2019. For more information, see our end-of-life article. If you'd like to migrate your data to Datto Workplace, see our migration guide.
To learn how to download your Datto Drive Cloud data, please visit this article.

Datto Autotask PSA: Why isn't my 2FA token working?

Follow

Issue

It's possible that even though a user may enter their Two-Factor Authentication (2FA) code correctly, they could still be told they have an invalid password.

Environment

  • Datto Autotask PSA

Cause 

The user may not have their time zone information synchronizing correctly with the servers. Since Time-Based One-Time Password (TOTP) services like Google Authenticator and Duo compare the time information stored on the phone to that of the Autotask user's time zone, we should check two things.

Resolution

Verify the User's Time Zone is Configured Correctly in Autotask

To check the user's time zone information:

  1. Navigate to Autotask menu → Admin → Features & Settings → Resources/Users (HR) → Resources/Users (HR) → Resources/Users.

Take note of the value in the Primary Location column. The value is assigned to the resource, and the location is then assigned a time zone.

To view the time zone of the location:

  1. Navigate to Autotask menu → Admin → Features & Settings → Your Organization → Internal Locations.

Verify the User's Time Zone is Configured Correctly on the Phone / App

Due to the large selection of app options different configuration available for each, the guides below are only a few of the common ones.

Google Authenticator

For Android-based devices, the time zone can be synchronized manually within the app. To make sure that you have the correct time:

  1. Go to the main menu on the Google Authenticator app
  2. Click More → Settings → Time correction for codes → Sync now

On the next screen, the app will confirm that the time has been synced, and you should now be able to use your verification codes to sign in. The sync will only affect the internal time of your Google Authenticator app, and will not change your device’s Date & Time settings.

For iOS-based devices, the time zone is pulled automatically from the device's location services. While you can set the time zone manually, most users chose to have the time set automatically by their location services. Sometimes issues like the aforementioned can be resolved by cycling the setting to set the time zone automatically. To do this:

  1. Launch the Settings app
  2. Go to General Date & Time
  3. Cycle the Set Automatically option off then on.

LastPass / Microsoft Authenticator / Authy

This application only uses the time zone information set on the phone. Consult the guide for your OS on how to change time zones. In addition, attempt to cycle your zone to another option and revert back, as this can usually resolve any localized device issues.

For more possible solutions to common issues with Google Authenticator, visit the article mentioned in the Additional Resources section below.

Additional Resources


Was this article helpful?

0 out of 0 found this helpful

You must sign in before voting on this article.

Want to talk about it? Have a feature request?

Head on over to our Community Forum or get live help.