Datto Autotask PSA: Why am I unable to edit the Exchange password for individual users in the MS Exchange extension configuration?

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Issue

In some cases, you are unable to edit the password for individual users. 

Environment

  • Datto Autotask PSA 

Cause

The checkbox to "Use these credentials for synchronizing individual user accounts" is checked under the Synchronization account details on the General tab of the Extension Setup.
In this scenario, the individual user accounts do not need to authenticate on Exchange to sync items, but the Synchronization account does this on their behalf by impersonating them.

Resolution

If you wish to change the setup in order for the individual user accounts to synchronize their own items instead of the synchronization account doing the sync on their behalf, please follow the path:

  1. Autotask menu Admin → Extensions & Integrations  Microsoft Extensions → MS Exchange → General tab → uncheck the checkbox for "Use these credentials for synchronizing individual user accounts" → Save

Once you save this change, the individual user passwords will need to be entered in order for the synchronization to continue working.

This procedure can be done in:

  1. User Profile → MS Exchange settings by the users themselves
  2. MS Exchange Extension Configuration -> Resources by System Administrators

You may want to use this setup when troubleshooting a synchronization issue to rule out a configuration problem with the synchronization account. See the troubleshooting article under Additional Resources

Additional Resources


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