Backupify/Datto SaaS Protection for G Suite and Office 365: Error: 400

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Issue

When backup services are set to archived, you receive the error message, "Error: 400: TokenResponseException," in the System Events and User Actions logs.

Environment 

  • Backupify/Datto SaaS Protection 1.0 for G Suite
  • Backupify/Datto SaaS Protection 2.0 for G Suite
  • Backupify/Datto SaaS Protection 1.0 for Office 365
  • Backupify/Datto SaaS Protection 2.0 for Office 365 

Cause 

The account is unable to access the API due to a permissions error. 

Resolution 

Ensure the user is a Super Admin (G Suite) or a Global Admin (Office 365). 

For G Suite, also ensure the Backupify/Datto SaaS Protection application is installed on the domain and enabled for everyone.

Notes

If you are using Backupify/Datto SaaS Protection 2.0, you can see the error message in any of the logs under the Reporting tab. Access your logs from your Backupify/Datto SaaS Protection 2.0 dashboard by navigating to the Settings tab → Reporting.

If you are using Backupify/Datto SaaS Protection 1.0, you will not be able to access any logs. To access your logs as a 1.0 user, please contact Datto Technical Support.


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