Unable to connect to IPMI

Issue

You are unable to connect to your Datto appliance's IPMI. You have ruled out hardware and networking configurations as a cause.

For IPMI password related issues, see New IPMI password parameters.

Environment

  • Datto SIRIS

Cause

The appliance's IPMI has stopped responding. You will need to reset it.

Resolution

  1. In the Datto device GUI, navigate to Configure > Device Settings > Shutdown Now to shut down the Datto device.
  2. Connect a keyboard and monitor to the device.
  3. Power the device on and press the Del key to enter the BIOS on startup.
  4. When prompted, type the BIOS password. You can get this password from Datto Technical Support.
  5. Select Server Mgmt, and press Enter. From there, select BMC Network Configuration.

bios1.png
Figure 1: BIOS BMC Network Configuration

  1. You will see the MAC address for your IPMI listed as NULL or FF:FF:FF:FF:FF: FF. If you do not see the MAC address listed this way, contact Datto Technical Support for further assistance.

NOTE  The location of your IPMI MAC address listing may be slightly different depending on your device. The above location is the most common one.

  1. Exit the BIOS and power the device down again.
  2. Once the appliance powers down, unplug it.
  3. With the device unplugged, hold down the power button for 30 seconds to drain all remaining power from the system. This procedure will trigger a hard-reset of your IPMI.
  4. Plug the device back into the power outlet.
  5. Power on the device and press the Del key to enter the BIOS again.
  6. Verify that the MAC address listed for IPMI is now correct.

If the above steps do not resolve the issue, contact Datto Technical Support for assistance.