iSCSI share connection fails with "Location is not available"
Issue
You are no longer able to reach iSCSI shares on your Datto device and receive an error that states, "Location is not available: X:\ is unavailable. If the location is on this PC, make sure the device is connected, or the disc is inserted and then try again. If the location is on a network, make sure you're connected to the network or Internet and then try again. If the location can't be found, it might have been moved or deleted."
IMPORTANT The wording of this error may differ depending on your OS. The example in this article is from Windows 10.
Environment
- Datto SIRIS
- Datto Alto
- Datto NAS
- Datto IRIS 3.89
- Microsoft Windows 10
Cause
After the Datto software update to IRIS 3.89, CHAP Mutual authentication requires that the CHAP secret and CHAP Mutual secret do not match. If you are using CHAP Mutual Authentication and your two CHAP authentication secrets match, you will need to change one of them.
Resolution
Figure 1 shows an example of this error on a Windows 10 system.
Figure 1: Location is not available error
- From the Datto device GUI, navigate to FILE SHARE > Network Attached Storage
Figure 2: Network Attached Storage
- Click Configure Share Settings for the iSCSI share you need to connect.
Figure 3: Configure Share Settings
- In the CHAP Authentication box, set the CHAP Secret and Mutual CHAP Secret to two different passwords. You can click the eye icon to make the password visible.
- Click APPLY.
- Update the iSCSI connection information on your connecting machines to reflect the new passwords.
You should now be able to connect to the share. If the connection still fails, contact Datto Technical Support.