Datto RMM: Error: "'CAG.pkg' can't be opened because Apple cannot check it for malicious software"

Follow

Issue

RMM fails to install on macOS Catalina with the error message, "'CAG.pkg' can't be opened because Apple cannot check it for malicious software."

Environment

  • Datto RMM
  • macOS Catalina

Cause

If an App does not come from the App Store, Apple automatically runs a scan to make sure it is not malicious. Apple cannot run the scan on our Agent Installer.

Resolution

cag1.pngFigure 1: Error message (click to enlarge)

1. Click OK.

2. Navigate to System Preferences → Security & Privacy → General.

3. Click Open Anyway.

cag2.pngFigure 2: General tab (click to enlarge)

4. Click Open again.

cag3.pngFigure 3: Error message (click to enlarge)

5. Click Continue to install the software.

cag4.pngFigure 4: Agent installer (click to enlarge)

You can also right-click CAG.pkg and select Open to bypass the error. 

Was this article helpful?

0 out of 0 found this helpful

You must sign in before voting on this article.

Want to talk about it? Have a feature request?

Head on over to our Datto Community Forum or the Datto Community Online.

For more Business Management resources, see the Datto RMM Online Help and the Autotask PSA Online Help .

Still have questions? Get live help.

Datto Homepage